Warning: ksort() expects parameter 1 to be array, object given in /home/bmitsakos/mitsakosaudio.com/wp-content/plugins/bbpress/includes/core/template-functions.php on line 316

Warning: Cannot modify header information - headers already sent by (output started at /home/bmitsakos/mitsakosaudio.com/wp-content/plugins/bbpress/includes/core/template-functions.php:316) in /home/bmitsakos/mitsakosaudio.com/wp-includes/feed-rss2.php on line 8
Uncategorized – Mitsakos Audio http://www.mitsakosaudio.com Tue, 30 Jun 2015 05:17:11 +0000 en-US hourly 1 https://wordpress.org/?v=4.9.2 Holy 31 Year Old Bug Fix Batman! http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Tue, 30 Jun 2015 05:17:11 +0000 http://www.mitsakosaudio.com/?p=130 Hey remember that bug I mentioned in my last post.  Well its fucking fixed!!!  Yeah, a Z80 firmware bug from the early 80s just got totally squashed 3 decades later.  If you are a gangster like Bob Grieb you just knock that shit out on a Sunday evening.

 

Bob just released two new firmware versions.  Version 12 is the latest and greatest firmware that fixes the version 11 bug.  Also available is the same patch for the version 09 firmware.  I have yet to give either of them a test drive but I will update here when I do.

You can grab the binaries here:  http://tauntek.com/SixTrackBug.htm

Thanks so much to Bob and to Stephan Kuempel.

Feeling inspired,

– Bill

 

]]>
http://www.mitsakosaudio.com/model610/feed 0
The Bug! http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Mon, 04 May 2015 15:29:55 +0000 http://www.mitsakosaudio.com/?p=121  

IMG_1218 1

HINT: Don’t upgrade Six-Trak to Firmware Version 11

Been battling a bug in the Six-Trak firmware and I think I’m finally going to have to admit defeat.

At first the bug appeared as a silent failure. When in stack mode (omni off, mono on), certain parameters on voices 5 and 6 are un-addressable.  Sending CC messages to toggle SAW and TRI waveforms or the LFO wave shape simply do nothing.  Oddly, toggling the PULSE waveform works fine.  This bad behavior is 100% reproducible on both the MAX and Six-Trak running firmware v.09.

The final version of firmware for the Six-Trak is v.11 which boasts better MIDI support.  I copped a v.11 ROM off ebay hoping it might fix this annoying bug.  To my dismay, it is much much worse.  Instead of failing silently, it now CRASHES THE SYNTH.  Arrrrgghhhh!!!

It seems the only viable workaround is to limit stack mode to the first 4 voices.  In the grand scheme of things its not the end of the world, but I’m not happy about it.

Also, there is a false black widow spider living on my back porch (pictured above).

Stay tuned for version Model610 v1.1 dropping shortly via the app store.  In addition to this workaround, it also has some other major improvements.

 

]]>
http://www.mitsakosaudio.com/model610/feed 0
Wicked Six-Trak Demo http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Sat, 18 Apr 2015 17:24:22 +0000 http://www.mitsakosaudio.com/?p=117

]]>
http://www.mitsakosaudio.com/model610/feed 0
Model610 Out Now!!! http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Thu, 16 Apr 2015 16:23:12 +0000 http://www.mitsakosaudio.com/?p=111 Grab it on the app store here!!!

 

]]>
http://www.mitsakosaudio.com/model610/feed 0
Juicy http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Sat, 28 Mar 2015 07:36:02 +0000 http://www.mitsakosaudio.com/?p=35 image

]]>
http://www.mitsakosaudio.com/model610/feed 0
A Sixtrack Controller App for the iPad http://www.mitsakosaudio.com/model610 http://www.mitsakosaudio.com/model610#respond Sat, 28 Mar 2015 03:18:09 +0000 http://www.mitsakosaudio.com/?p=12

Thanks to Stephen Fortner for shooting this video at the I/O Synth meet last month.

]]>
http://www.mitsakosaudio.com/model610/feed 0